Jump to content
×
×
  • Create New...

issue with objects sometimes not being found inside stream


Recommended Posts

I'm making a script for runecrafting blood runes in arceeus. My script works fine at the start and both "Dense runestone" objects can be queried just fine. But whenever the script leaves the area and comes back, the queries cannot find the object anymore.

val runeStone = ctx.objects.toStream().name("Dense runestone").nearest().first()

above is the query i'm using. I checked the list of objects and it's not there.

Link to post
Share on other sites
  • Administrators
On 5/18/2021 at 8:18 AM, blokys said:

I'm making a script for runecrafting blood runes in arceeus. My script works fine at the start and both "Dense runestone" objects can be queried just fine. But whenever the script leaves the area and comes back, the queries cannot find the object anymore.

val runeStone = ctx.objects.toStream().name("Dense runestone").nearest().first()

above is the query i'm using. I checked the list of objects and it's not there.

What's the id? What client version are you using?

Link to post
Share on other sites

Definantly some issue with interacting with the sack at motherlode, as it works completely fine on desktop. seems like its the same issue blokys is explaining, i tried on LDplayer, bluestacks and emulator, all of which didnt work properly.

Link to post
Share on other sites
  • Administrators
On 5/24/2021 at 1:11 PM, rs1007 said:

Definantly some issue with interacting with the sack at motherlode, as it works completely fine on desktop. seems like its the same issue blokys is explaining, i tried on LDplayer, bluestacks and emulator, all of which didnt work properly.

This has been resolved?

Link to post
Share on other sites
17 hours ago, const_ said:

This has been resolved?

I dunno what the issue tbh, after restarting for about 5 times, it might work one of the times and i can run it as long as i want. But after i restart the client it stops working again, it seems to be a wierd issue only i have been having

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.